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What does CityDesk do? 
CityDesk makes it easy to manage a web site which changes 
often. 

With CityDesk, people who don't know anything about HTML 
or web servers can easily add, edit, and remove articles from a 
web site, using a program that is as easy as a word processor. 
CityDesk will automatically apply standard formatting, 
according to templates you provide, to those articles. Then it 
copies them to your web server automatically. Each article can 
include pictures, sounds, and other media elements. 

Here are just a few examples of the kinds of things you can 
build and maintain with CityDesk: 

• A daily newspaper, a monthly newsletter, or a web-based 
magazine  

• A personal journal or weblog  
• A company's list of job openings  
• A real-estate agent's list of currently available properties  
• A company worldwide knowledge base 

The real power in CityDesk comes from the fact that you only 
design the formatting of your site once. After that, it's easy to 
create new articles which use the same design. Because 
CityDesk keeps the text of the articles separate from their 
design, you can change the design in one place, and every 
article on your site changes accordingly. 

Once you set up your site, updating it is just as easy as using a 
simple Windows-based word processor. The built-in word 
processor is WYSIWYG ("What You See Is What You Get") 
and includes a spell checker, word counter, find and replace, 
and formatting commands. 
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CityDesk is built around a powerful, robust database engine. 
This means that different people can update the site 
simultaneously without any risk of conflict or corruption. You 
can even have a whole newsroom banging away at the same 
time; even a virtual newsroom, with contributors all over the 
Internet! 

When you need to manage a site with several different versions, 
CityDesk is invaluable. Suppose you want to publish a 
newsletter every week in two languages. CityDesk provides a 
nice interface for translators where they can see a list of 
untranslated articles and translate them on the spot in a split-
screen environment. If you try to publish the site before 
everything has been translated, you'll see a warning. 

Or suppose you produce a newsletter that has different regional 
editions. Most of the articles are the same, but you don't want to 
run your poem "Every Civilized Person Loves the New York 
Yankees" in the Boston edition. CityDesk keeps track of that 
and publishes both editions completely automatically. 

CityDesk can also keep track of articles that need to be held 
until a certain date. Just write the article and set the date range, 
and CityDesk will never publish it before or after those dates. 
This is a good way to keep fresh content on your web site when 
you're on vacation. 

Many web sites appear in multiple formats. For example, you 
might have: 

• the normal web version  
• a "printer-friendly" web version without ads or navigation 

elements  
• a version for Palm Pilots without pictures  
• a large-font version for the web site for people who like 

larger fonts  
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• a printed version that you hand out on street corners to 
passers-by (who use it to line bird-cages, those scurvy 
knaves)  

• and so on and so forth. 

Setting up template families for each of these versions is a one-
time operation. After that, you only have to type in the article 
once, and it will automatically be published in each and every 
format without any additional work. Ta da! 

We think you'll find that CityDesk is an extremely powerful 
tool, but one that's quite easy to understand. This tutorial will 
take you on a whirlwind tour in about ten minutes. After that, 
you'll only need to consult the documentation occasionally. 

Ready? Let's get started!  
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Lesson 1 - Creating a Simple Site 
In CityDesk, every element of your site -- articles, HTML files, 
templates, pictures, and anything else you want to publish -- is 
stored in a single file on your hard drive. When you create a 
site, you're really just creating one file. 

  Start CityDesk, if it is not already running, by choosing 
Start » Fog Creek Software » CityDesk. 

If you have used CityDesk before, it will open the same site as 
you were last editing. In this case: 

  Select File » New Site 

If this is the first time you've run CityDesk, you'll see a 
welcome dialog. In this case:  

  Click on Create a new CityDesk site 

A dialog box will ask you to name your site and save it on your 
computer.  

  Type a name for your site and click Save.  

As you can see, you have now created a new site with a front 
page called index.html. There is a folder called Articles and a 
single article called Getting Started...  

  Try double clicking on the Getting Started... article. You can 
edit it using the built-in word processor. 

  Click Save and Close.  
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Lesson 2 - Previewing the Site 
The Preview command lets you see what your site will look like 
without publishing it to a web server. It publishes a complete 
copy of your site into a temporary directory on your own hard 
drive. 

  In the main window, click on the Preview tool on the 
toolbar. 

A status window appears showing the publish progress. 
CityDesk is combining the text of all the articles on your site 
with their respective templates to generate complete HTML 
pages. 

When everything is done, a button appears which lets you 
preview your site using Microsoft Internet Explorer. 

  Click on the Internet Explorer button. Have a look at this 
simple site, with only one article. 

  Close the web browser and click the Close button on the 
Publish window. 

In the next lesson, we'll add another article. 
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Lesson 3 - Adding a New Article 
Let's create another article. 

  In the main window, click on the Articles folder. (In 
CityDesk, you can use folders any way you want to sort and 
organize articles.) 

  Select File » New » Article or click on the New Article 
tool. 

A new article will appear. Since the Articles folder was 
selected, that's where it will go.  

  Type a name for the article and press Enter. 

  Double click the article you just created. A window will open 
up and you can just start typing away. Write something funny 
about anteaters. 

CityDesk's built-in word processor lets you format, spell-check, 
create hyperlinks, insert pictures, and edit all the attributes of 
your article. 

  In the article window, click on the tab that says Properties. 

Here you can select options that affect how your article will 
appear. For example, you can write a headline or select which 
template to use. You can also schedule your article to be 
published on a certain date or associate certain keywords with 
the article for searching later on. 

  Provide a headline for your article. Type your name in the 
author box. Don't be bashful! 

  In the article window, click on the tab that says Extras. 
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This is where you write other pieces of the article such as the 
teaser. (A teaser is a short introduction to the article that makes 
people want to read more.) Where these pieces appear depends 
on the template you are using. 

  Type a teaser and a sidebar. 

  Click Save and Close. 

  Preview your site again. Notice that your new article 
now appears next to the original one. 
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Lesson 4 - Changing the Appearance of 
Articles 

You can change the appearance of all your articles in one place 
just by changing the template. 

  Make sure Designer Mode is on by selecting 
View » Designer Mode. When designer mode is on, a row of 
extra designer tools will appear in the toolbar. 

  Select View » Templates or click on the Templates tool 
on the tool bar. 

  Double click on the template titled Simple (.html). 

A template is an HTML boilerplate document containing all the 
stuff that is the same for every article which uses it. Any change 
you make here will change the appearance of all articles that use 
the template. You can have as many templates as you want. 

More advanced changes can be made by clicking on HTML 
View and editing the HTML directly. You can also edit the 
template using a more sophisticated HTML editor such as 
Macromedia Dreamweaver, Microsoft FrontPage, etc. To use 
any external editor that is registered on your system, just right 
click on the template icon in the Templates window. 

Everything you see between {$ and  $} is a CityScript element 
that will be replaced when you publish your site. CityScript is 
CityDesk's built-in scripting language. It's very easy to learn 
and you don't have to be a programmer. 

For example, {$.headline$} will be replaced by the actual 
headline of each article. (The article's headline comes from the 
Properties tab in the article editor.) {$.body$} is replaced by 
the main text of the article. 
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CityScript also lets you create variables. Variables represent 
chunks of text that can be changed in one place, affecting the 
entire site. For example, a company's name might appear on 
every page of the site, represented by a variable. In the case of a 
merger, buy-out, or if the name turns out to be obnoxious in 
Basque, the company's name can be changed just once on the 
variable list and this change will be reflected everywhere it 
appears on the site. In this template, we use two variables: {$ 
.SiteName $} and {$ .TagLine $}. 

  Close the Simple Template window and the Templates 
window beneath it. 
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Lesson 5 - Changing the Front Page 
CityDesk lets you drag any file you want into your site: 

• HTML files 
• Pictures 
• Other text files 
• Other binary files 

These files can be sorted into folders. The entire tree will be 
published on your web server. 

Your site contains one such file, an HTML file called 
index.html. This is there because most web servers look for a 
file named index.html to display when web visitors enter the 
site. 

  Double click on index.html from the main window to edit the 
front page. 

This opens up the front page in a built-in word 
processor. HTML files can contain CityScript just like 
templates. 

What's going on in this file? Let's look at the CityScript one line 
at a time. Follow along:  

{$.SiteName$} 
The dot here tips us off that SiteName is a variable. When this 
page is published, CityDesk looks for a variable named 
SiteName and prints its value here.  

{$.TagLine$} 
Another variable, using a smaller font this time.  
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{$foreach x in (all)$} 
This is the beginning of a loop. CityDesk will repeat everything 
between the foreach statement and the next statement once for 
every article in the site. 

{$x.headline$} 
This pulls out the headline from the article. Notice that this 
appears in blue with an underline. You know what that means, 
right? Right! It's a link! Specifically, a link to the article itself. 
This was done by editing in HTML View, where the headline is 
coded as:  

<A href="{$x.link$}">{$x.headline$}</A>  

CityDesk replaces {$x.link$} with the article's actual URL at 
publishing time. 

{$setDateTimeFormat "English" "dd MMM, yyyy" 
"hh:mm"$} 
This sets the format that CityDesk will use for printing dates. 
Why do we care? Well, because we're about to print a date: 

{$x.fileddate$} 
Ah yes, that prints the date that the article was filed.  

{$x.teaser$} 
This displays the teaser field from the article: a short block of 
text on the home page that makes people want to read the 
article.  

{$next$} 
And that's the end of our loop. If there are any more articles 
remaining that we haven't printed, CityDesk jumps back up to 
the foreach statement and runs through it all again, this time 
assigning x to a different article. When we've finished listing all 
the articles, CityDesk will stop looping.  



CityDesk Tutorial 

14 

  Close the index.html window. 
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Lesson 6 - Changing a Variable 
Variables, which are elements of CityScript, can be used in 
articles or in templates to represent chunks of text you need to 
use more than once throughout your site. When CityDesk 
publishes a site it replaces all variables with the text each 
represents. 

Suppose you have a mentally unstable boss who asked you to 
create a web site praising the Boston Red Sox. Since you know 
he is mentally unstable, instead of writing 

The Boston Red Sox rule the Earth  

you define a variable FlavorDuJour which is defined as 
Boston Red Sox. Now you can write things like: 

The {$.FlavorDuJour$} rule the Earth  

and 

All hail the {$.FlavorDuJour$}!  

As you can see, to use the variable name, we surround it 
with {$. (note the dot) and $} (no dot). 

Now, next week, when psycho-boss wants you to change the 
site to praise, say, the Mighty Ducks instead, you just change 
the variable FlavorDuJour in one place and CityDesk takes 
care of the rest. 

In the default set-up, the Simple template has a variable 
SiteName used for the title at the top of each page. To change 
the text inserted, just change the value of the variable. 
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  In the main window, select View » Variables or click 
on the Variables tool on the toolbar. 

You'll see a list of each variable’s name and the text it 
represents.  

  Double click on the variable called SiteName and give it 
another value. Give your site a name that reflects your 
individuality and creativity, like "Welcome To Jim's Home on 
the Web" (assuming that your name is Jim, of course).  

Each time CityDesk sees something that looks like 

{$ .SiteName $} 

it will replace it with the text you just typed in. 

  Preview your site and notice how the title has changed on 
every page. 
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Lesson 7 - Publish to an FTP Server 
Your web site is not much good if people can't see it! For 
people to see it, it has to be on a web server somewhere. The 
Publish command uses the Internet FTP protocol to copy all the 
final files onto a web server. (Optionally, it can also copy the 
site into another folder, simply copying the files to a destination 
you choose.) 

  Click on the Publish tool in the toolbar or select 
File » Publish. 

This will bring up the Publishing window. Since this is your 
first time publishing to an FTP server you need to tell CityDesk 
where you want to publish the site. From the Publish window: 

  Click on Edit Locations... button (you must be in Designer 
Mode to see this button). 

  Click on Add button 

  Set up publishing options (via a wizard): 

  For the method, select FTP (you can also publish by 
just copying the files to a folder, locally or on the 
network) 

  Enter the server information (server name, username, 
password, subdirectory, and the URL) for your web 
server 

  For Template Family click Next. 

  For Select Language click Next. 

  For Target Audience click Next. 
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Template, Language and Target Audience are more 
advanced features described elsewhere in the 
documentation. 

  Give the location a meaningful name, like "asdf", and 
click Finish.  

  Close the Publish Locations window.  

You can create as many publish locations as you need with 
different names. For example, if you have a web server in 
France and another one in the United States, you can set up a 
separate publish location for each one. Or, for example, your 
might set up two publish locations if you maintain an internal 
web server for testing and an outside web server for the final 
web site. 

  In the main Publish window, choose the publish location you 
just created (asdf?) and click on the Publish button. 

CityDesk will generate the HTML files and transfer them over 
to the server. 

Now that you've set everything up, in the future you can publish 
to this FTP server just by clicking on the publish tool. 
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Lesson 8 - Editing from Your Web Browser 
Murphy's Law requires that all web sites contain embarrassing 
typographical errors (like calling to the CEO of your company 
"Old Farthead" instead of his actual name). When you're 
looking at your own web site on the web, it's nice to be able to 
fix those the minute you notice them.  

When you first ran CityDesk, it installed a tool bar icon in 
Internet Explorer that lets you edit pages that you created with 
CityDesk. When you click on the icon, a new copy of CityDesk 
starts up and takes you right to the article you were looking at.  

 
To use this feature to edit a file, you need be at the 
computer that has the original CityDesk file. 

  Use the Preview button to preview your site. Click on the 
Internet Explorer button to view it in Internet Explorer. 

  In Internet Explorer, click on the link to the Getting Started 
article. 

  Click on the down arrow to the right of the Edit button in the 
Internet Explorer toolbar. Choose Edit with CityDesk from the 
list. 



CityDesk Tutorial 

20 

Another copy of CityDesk will launch and take you directly to 
the Getting Started article, which you can easily edit, save, and 
republish. 

Note: If you don't see the Edit button in Internet Explorer, you 
may have to customize your toolbar. Here's how: 

  In Internet Explorer, right-click on the main toolbar 
(this is the one that has Back, Forward, etc.) 

  Click Customize...  

  Find the Edit button on the left hand list and click 
Add. 

  Click Close. 
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Lesson 9 - Making Backups of Your Site 
Generally, when you make a change in CityDesk, 
it's permanent. So you should always make frequent backups of 
your site. 

Because CityDesk stores everything in one big file, making a 
backup of your site is very simple: just exit CityDesk and copy 
the file to a safe location. 

Remember: It is not sufficient to back up the web server where 
you publish your site. This will only preserve the final form of 
your site in HTML format, not the CityDesk database which 
generated it. 

Well, that's the end of our tutorial! You know enough about 
CityDesk to be dangerous. For everything else, we have 
complete documentation. Enjoy! 
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